Page 1 of 1

80beta3: copying (Ctrl-C/Ctrl-Ins) a field in the tag grid

Posted: Sun Oct 03, 2010 6:40 am
by hopalongrock
(when the field only selected, no input) There's an unwanted Tab character at the end of string.
This doesn't happen before 080 version.

Re: 80beta3: copying (Ctrl-C/Ctrl-Ins) a field in the tag grid

Posted: Sun Oct 03, 2010 9:08 am
by jtclipper
I tried to reproduce this but no tab character is appended to the value

Re: 80beta3: copying (Ctrl-C/Ctrl-Ins) a field in the tag grid

Posted: Sun Oct 03, 2010 10:27 am
by hopalongrock
This happens with the 3 new betas, even in my maintenance partition only with Zonealarm Pro installed.
I am using Windows XP Sp3.
When I copy a field and paste into another field, it's ok.
But when I paste into notepad i get tab after the field, in tag template again I see the tab after the text.

Edit:
(But the paste is good in the tag template, when the value field is only selected;  the appended tab appears when I paste into a field in input)

Re: 80beta3: copying (Ctrl-C/Ctrl-Ins) a field in the tag grid

Posted: Mon Oct 04, 2010 11:02 am
by jtclipper
The tab character is used internally by the grid control to make it possible to copy/paste multiple cells around.

Using another application like notepad will display those tab characters nothing I can really do about it other than eliminate
the tab characters before you use paste.
But doing that will remove the copy/paste of multiple cells functionality and I don�t really want this to happen.

Re: 80beta3: copying (Ctrl-C/Ctrl-Ins) a field in the tag grid

Posted: Mon Oct 04, 2010 11:44 am
by hopalongrock
Dimitris wrote:The tab character is used internally by the grid control to make it possible to copy/paste multiple cells around.

Using another application like notepad will display those tab characters nothing I can really do about it other than eliminate
the tab characters before you use paste.
But doing that will remove the copy/paste of multiple cells functionality and I don�t really want this to happen.


In the Manual Edit we had Copy: Ctrl+C and Paste: Ctrl+V menu items/keys for multi column copy,
now in the Tag we have Copy tag and Paste tag menu items and Ctrl+C, Ctrl+V for a single grid field copy.
I think that at least function level the single and multiple field/tag copy is separated, and you could remove the the tab character in the 'grid control' doing this single field copy. I suppose that this 'grid control' is part of tgf and not part a foreign library.

But maybe you could remove the last tab character from the string before the paste.
This is good for a single field, and doesn't disturb the multiple column paste function.

Re: 80beta3: copying (Ctrl-C/Ctrl-Ins) a field in the tag grid

Posted: Mon Oct 04, 2010 1:13 pm
by jtclipper
The grid control is a component and yes it is foreign code.
The only thing I can do is strip off the tab characters before the paste happens in the grid itself, that will not solve much because the last tab char is ignore by the grid component.

The workaround is to hit enter to enter edit mode for the single cell and use ctrl_c then.
Will keep an eye out for it though maybe something could be worked out.

Re: 80beta3: copying (Ctrl-C/Ctrl-Ins) a field in the tag grid

Posted: Mon Oct 04, 2010 1:32 pm
by hopalongrock
Dimitris wrote:The grid control is a component and yes it is foreign code.
The only thing I can do is strip off the tab characters before the paste happens in the grid itself, that will not solve much because the last tab char is ignore by the grid component.

Because the paste into the grid works well now, there's no need to do this, I think.
Maybe the best is, if you do nothing. If I want to copy a field and don't want the closing tab, I left click or Enter on the field, and copy from the input field.