BUG: MP4/M4A/M4B tag edits lose the pictures

Main discussion forum
jbscout
Newbie
Newbie
Posts: 11
Joined: Sun Oct 31, 2010 3:19 am

BUG: MP4/M4A/M4B tag edits lose the pictures

Postby jbscout » Mon Mar 28, 2011 4:06 am

I have noticed in both 0.80 & 0.79 if you edit a *.m4b file that includes a picture, you'll lose the picture.
The Godfather will correctly read the tag.
The Godfather will correctly edit the "text" tags, but
The Godfather will delete the embedded picture from the *.m4b tag, even if you didn't want to touch the picture field.
.
Tested with editing both the genre & title fields in two respective *.m4b files.
.
I am assuming TGF reads the tag, makes changes in RAM, then edits the tag by deleting the old tag and writing a new one.  Somewhere in the read/write process the picture goes missing.

jtclipper
Administrator
Administrator
Posts: 586
Joined: Tue Aug 10, 2010 12:04 pm

Re: BUG: MP4/M4A/M4B tag edits lose the pictures

Postby jtclipper » Mon Mar 28, 2011 11:51 am

Please send me one of those files so i can check what happens.
Dimitris

jbscout
Newbie
Newbie
Posts: 11
Joined: Sun Oct 31, 2010 3:19 am

Re: BUG: MP4/M4A/M4B tag edits lose the pictures

Postby jbscout » Sun Apr 03, 2011 9:02 pm

Each file is about 89Mb.  So, I am not able to mail them to you.
Each file was created via "Chapter & Verse" which joins M4Bs and adds chapter markers.
TGF 0.80 is running on a WinXP SP3 32-bit machine
TGF 0.71b2 (not sure why I thought it was 0.79) is running on a Win7 Ult 64-bit

The original file is:  http://rapidshare.com/files/455742201/Pronto_Original.m4b
The 0.71b2 edited file is: http://rapidshare.com/files/455750180/Pronto_TGF_071b2.m4b
The 0.80 edited file is: http://rapidshare.com/files/455753891/Pronto_TGF_080.m4b

In both cases I edited the Year tag and saved the file.
In 0.71b2 I used "Manual edit" tab
In 0.80 I used the "Full Tag edit (Ctrl-G)" right-click menu option from the "Tag" tab.

It may be that C&V is storing the image in a weird way (e.g., with the chapter markers).  Just wild speculation.

jtclipper
Administrator
Administrator
Posts: 586
Joined: Tue Aug 10, 2010 12:04 pm

Re: BUG: MP4/M4A/M4B tag edits lose the pictures

Postby jtclipper » Mon Apr 04, 2011 2:33 pm

Thanks for submitting the file.
I found the problem its a flag that was set that makes TGF think its a bmp file when the actual cover is a jpeg file.
Will be corrected in the next beta release
Dimitris


Return to “Requests - Questions”

Who is online

Users browsing this forum: No registered users and 1 guest